Loading ...

User Profile - email field issue preventing profile updates | Communifire Support

Home » Spaces » Communifire Support » forum » Report Bugs and Issues » User Profile - email field issue preventing profile updates
Communifire Support

Leave Space :

Are you sure you want to leave this space?

Join this space:

Join this space?

Edit navigation item

Required The name that will appear in the space navigation.
Required
Required
Required The url can point to an internal or external web page.
 
Login to follow, share, and participate in this space.
Don’t have a support community login?Create your account now
Posted in: Report Bugs and Issues

User Profile - email field issue preventing profile updates

Subscribe to RSS
  • We have had multiple users encounter an issue when trying to update their profile. These are the steps we're taking to encounter the issue:

    User clicks on "Edit Profile"

    As it stands, when a user clicks in here, we are seeing that their email field shows our standard email prefix of the first initial followed by last name, for example: "aporter" ... this obviously is not their entire email address but this is what we are seeing.

    Then a user makes an update to their 'about me' or 'phone' field etc, and clicks on "save" and they get an alert that the email field in "contact info" is invalid.

    User then enters full email address, for example, "aporter@domain.com", and clicks save, and then receives an alert saying "already taken, choose another" (see picture below)

  • Hi Anna,

    I restarted your site to refresh the site data. I can see the full email address when I edit a user's profile now. Could you check whether this is working for you and whether you can edit and save your profile now?

    Grace

    Anna Porter
    Anna Porter
    Thank you - I see full email address in the field now - I'll ask a couple users to test and follow up. Thank you!
    6 days ago
  • Well shoot. That worked for some users but not all... some are still experiencing the issue. I directed them to sign out/ sign in / and refresh etc - but they still came up with the same issue as previously encountered:

  • Hi Anna,

    I see that your account still has the domain. Could you test logging out and logging in via SSO? Does this remove the domain from your email address? I suspect this could be the cause.

    Grace

  • I completely logged out & then in again and my email is again loading without the domain suffix which seems to recreate the issue where it requires you to update the email field but then says that the name is already taken:

  • Hi Anna,

    Were any changes made to SSO settings recently? Either in Communifire or in Okta?

    Grace

    Anna Porter
    Anna Porter
    I don't think so but I don't know - I've posed this question to our IT Dept. and will get back to you
    6 days ago
  • This was the reply from our IT Dept: "we’ve not made any changes to the SSO application that Connect uses. If you need to include me in a call to look over the OKTA side of things I’d be happy to assist."

  • Hi Anna,

    Thanks for confirming. I've forwarded this issue to our development team. I'll let you know what they find.

    In the meantime, you can restart the site to make email domains appear again. However, if a user logs in via SSO after the restart, the issue will recur for them. We're looking into a permanent fix.

    Grace

  • All our users sign into Connect directly through Okta so yes they will be accessing the site via SSO daily/ so would continue to run into this issue. Thank you for taking it up with your development team.

  • Hi Anna,

    We are looking into this issue on high priority basis.

    Thanks,
    Raghav 

  • Hi Anna,

    Can you please try to relogin again?

  • I've logged out and back in and I see my full address; I've asked some colleagues to let me know what they see too:

    Some see their name in caps followed by our domain.com; I see my name in lower case followed by our domain.com

    STAPIA@domain.com 

     MARLT@domain.com

    aporter@domain.com 

    AND so far so good - looks like people are able to edit their profiles again  - Thank you!

     

Page 1 of 1 (12 items)