Loading ...

Bypass first time user "required info"? | Communifire Support

Home » Spaces » Communifire Support » forum » Report Bugs and Issues » Bypass first time user "required info"?
Communifire Support

Leave Space :

Are you sure you want to leave this space?

Join this space:

Join this space?

Edit navigation item

Required The name that will appear in the space navigation.
Required The url can point to an internal or external web page.
Login to follow, share, and participate in this space.
Don’t have a support community login?Create your account now
Posted in: Report Bugs and Issues

Bypass first time user "required info"?

Subscribe to RSS
  • Is there anyway to just let SSO users see "public" pages instead of having to fill in the "required info" upon first login?


  • gskamau

    Hey Jacqueline,

    Users see the page to complete their profile because some profile fields are marked as required. If you want users to skip the complete your profile page, you must mark the profile fields as optional. To do this, follow the steps below.

    1. Go to Control Panel > People > User Profiles 
    2. Edit Edit Profile Page 
    3. Edit the profile field
    4. Set Number required to 0
    5. Save the field

    Do this for all profile fields that have been marked as required, then publish the page. You may also need to Edit User Preferences Page if any required fields are on the user preferences page.


  • Thanks, Grace.  I see where to make the change by setting the field to "0", however, i'm not able to edit and I am a site admin.  See attached.

  • raghav_khunger

    Hi Jacqueline,

    I think "First Name" and "Last Name" fields should already be coming from SSO.

    Do you want the "First Name" and "Last Name" fields also to be "not required"?



  • I see.  You're right.  We're all set.  Please close the ticket.  Thank you.

  • Apologies, one last follow up.  I cannot seem to find this "chat apps" section to edit.  What page is this?


  • gskamau

    Hey Jacqueline,

    The Chat Apps field wasn't on either the edit profile page or the user preferences page. I added the field to the edit profile page, made it optional, published the page, then removed the field and published the page again. Users shouldn't be prompted to complete this field on first login now.


  • Thank you, thank you.

Page 1 of 1 (8 items)