Loading ...

Content access | Communifire Support

Communifire Support

Leave Space :

Are you sure you want to leave this space?

Join this space:

Join this space?

Edit navigation item

Required The name that will appear in the space navigation.
Required
Required
Required The url can point to an internal or external web page.
 
Login to follow, share, and participate in this space.
Don’t have a support community login?Create your account now
Posted in: Features and Functionality

Content access

Subscribe to RSS
  • Hi, 

    So we have set up our permissions that there are three main overarching spaces that all staff have access to; Operations, CCP Announcements, and Technical.  These are private moderated spaces. We have under Technical created a series of public spaces that we want all staff to be able to see. Our understanding was that because the overarching main space was private, those spaces content would be private to people we may only give access to one sub-space. But when I'm creating the homepage, the content is populating regardless of permission to those public sub-spaces under private spaces. In addition, that content is showing up in the search. But only for those public sub-spaces. Not sure if I'm explaining this well. Let me know. We are launching to our partners on the 16th, right now they seem to have access to things I don't want them to see. 

    Thank you, 

    Rebecca 

  • Like this dummy account only has access to Breakthrough ACTION which is a sub-space of technical. But they are getting results from other sub-spaces. 

  • Hi Rebecca,

    Even if a parent space is Private, if a subspace is public, all users will be able to see them and the contents that are in them. So when a user searches for content, anything in those public subspaces will show.

    You may want to consider making these spaces private as well if you would like to limit what users are seeing.

    Thanks,
    Foster

  • Foster,

    We were told that the sub spaces of a private space are private if you aren't a member of the main space. 

    Thanks,

    Rebecca

  • Nathaniel Stiers - any other insight here. 

  • Hi Rebecca,

    This appears to be a bug. I've made our developers aware of the issue. We'll let you know once it's fixed.

    Grace

  • Hi Rebecca,

    This is actually not a bug. Content in a public sub space of a private space will appear in search if the space's Guest role has View permission for content types. The parent space's visibility doesn't determine whether the sub space's content appears in search or not.

    To change this for your public sub spaces, go to Manage Space: Permissions and select a content type. Uncheck the View permission for the Guest role, then click Save Changes. Do this for all content types.

    We've designed it this way in the interest of search performance. If you had a bunch of nested spaces, every parent space would need to be checked in order to determine whether a specific nested space should appear in search or not. Instead, we check just that space's content permissions.

    Grace

  • Ok I will go through and make these adjustments. i'll let you know if I have additional questions. 

    Thank you, 

    rebecca 

  • Our Research and Evaluation space, which is public under a private main space, is showing up in the recent discussions for everyone even those who are not members of that space. I have changed the permissions for this space so there is no view for anything if you are a guest. Could you assist? In addition, even those that are not members of the main space, are seeing those discussions. 

    Thank you,

    Rebecca

  • Hi Rebecca,

    Each forum has its own set of permissions. You'll need to update the permissions for each forum. To do this, go to Manage Space > Discussions and edit a forum. You'll see a permissions section. Update those permissions, then click Save Permissions.

    This is what that area looks like:

    The screenshot you shared sets the default permissions for new forums.

    Grace

  • Grace, 

    Is there anyway to change the default permissions for our content types so that even when it is a public space the guest can't view it? Or is there a quicker way then manually doing this for all our spaces? We have like 60 now. 

    Thank you,
    Rebecca 

  • I have also now gone through all the forums and changed the permission level to not show on Guest and the content is still showing up on the homepage. 

  • Hi Rebecca,

    Please provide a list of the spaces which should have the View permission disabled for the Guest role. Feel free to open a private case here if the information is sensitive.

    We are investigating the discussions.

    Grace

  • Grace, 

    Did I create the case? I think I might have deleted it. 

    Thank you, 

    Rebecca 

  • Hi Rebecca,

    I don't see a new case from you.

    Grace

  • Answered

    Hi Rebecca,

    Thank you for creating the case.

    Regarding the discussions from the Research and Evaluation space appearing on the homepage for non-space-members - the View permission was still checked for one of the forums. I unchecked that permission. Is this working correctly now?

    Grace

  • Yes it looks good. 

     

    Thank you,

    Rebecca 

Page 1 of 1 (17 items)