Loading ...

Comments option missing from discussion post | Communifire Support

Home » Spaces » Communifire Support » forum » Features and Functionality » Comments option missing from discussion post
Communifire Support

Leave Space :

Are you sure you want to leave this space?

Join this space:

Join this space?

Edit navigation item

Required The name that will appear in the space navigation.
Required The url can point to an internal or external web page.
Login to follow, share, and participate in this space.
Don’t have a support community login?Create your account now
Posted in: Features and Functionality

Comments option missing from discussion post

Subscribe to RSS
  • Hello -

    We spent a good amount of time going through all the forums and discussions to make sure the members couldn't POST/CREATE or delete.  But when we only added "view" then their option to comment disappeared. So we tried to add back "edit" and "add an attachment", along with view.. still nothing (no option to comment). 

    What are we missing here?  We want the members to be able to comment, we just don't want to be able to create or delete or edit what we've done?

  • Hi Tiffany,

    It isn't possible to allow users to reply to discussions but not create discussions. The Create Post permission is for creating new discussions and replying to discussions. Other content types such as articles, blogs, and wikis can be commented on without permission to create new content.


  • Uh oh.  Ok.  This is going to get interesting :).  

    We will give it a shot to try and make sure they understand they are NOT to use this as a support group/ask off topic questions and see if that works. If not, we will need to come up with an alternative solution. 


    Thank you -

  • Answered

    Hi Tiffany,

    You can set up content moderation in the forums to make sure only approved discussions are posted. Follow the steps below to do this.

    1. Go to Manage Space > Workflow > Workflow Settings
    2. Set Forum Workflow to Yes
    3. Click Update Workflow Settings
    4. Click Discussions in the left menu
    5. Edit a forum
    6. Set Workflow to Yes

      The Default Forum Workflow will be selected automatically
    7. Click Update

    Repeat steps 5-7 for each forum.

    Now anyone who creates a discussion in a forum and isn't a Moderator will have to have their discussion approved. Anyone who is a Moderator will automatically have their discussions approved.

    By default, people with the space Moderator role can approve or decline discussions. If you'd like to change which role moderates discussions, go to Manage Space > Workflow > Workflow Definitions and either edit the default discussions workflow or create a new workflow. Refer to the Manage Space: Add Workflow and Manage Space: Edit Workflow documentation.


  • Wow - TY!  There is so much to know and absorb.  We are building our site in less than 3 weeks (launching Monday) so it's been quite a learning curve. Thank you (and everyone there) for making this an easy transition.

  • Hi Grace,

    We have changed the settings to moderate posts, but now when trying to comment, we receive a message that the comment has to be approved by moderators.

    Is there a way to make the discussion posts moderated, but the comments be unmoderated? We want people to be able to comment freely, but we do not want unmoderated discussion posts.

  • Hi Tiffany,

    Is Forum Reply Workflow disabled in Manage Space > Workflow > Workflow Settings?


  • Grace,

    The Forum Reply Workflow is not disabled. It is turned on.


  • Answered

    Hi Tiffany,

    If you'd like comments on discussions to be unmoderated, disable Forum Reply Workflow.


Page 1 of 1 (9 items)