Loading ...

Non-adminstrators creating top level wikis and groups | Communifire Support

Home » Spaces » Communifire Support » forum » Features and Functionality » Non-adminstrators creating top level wikis and groups
Communifire Support

Leave Space :

Are you sure you want to leave this space?

Join this space:

Join this space?

Edit navigation item

Required The name that will appear in the space navigation.
Required
Required
Required The url can point to an internal or external web page.
 
Login to follow, share, and participate in this space.
Don’t have a support community login?Create your account now
Posted in: Features and Functionality

Non-adminstrators creating top level wikis and groups

Subscribe to RSS
  • We are going through the whole site and essentially turning off member access to "creating" anything. (We are a nonprofit, using this site to house projects, so members are participants and cannot create or edit anything). 

    While we are now privy to how to turn off in GROUPS, we can't figure out how to turn off in Top Level?  I was able, as a member/non-admin, to create a wiki at top level.  I was also able to create a Group - we can't have that either. 

    I've looked through the Control Panel for top level for creating things (wikis, groups) and cannot figure out how to shut these features off for members.

     

    Attachments
  • Hi Tiffany!

    You can edit permissions for top level content by going to Control Panel > Content > Choose the content you would like. Then select Permissions on the lefthand side.

    It looks like for Wiki's you have Moderators and Members able to Create.

    You can uncheck most/all of the boxes for members and moderators if you would like them not to be able to create wiki's. 

    I hope this helps,
    Foster

  • Thank you - Ok, we finally have all permissions for members turned off everywhere, in every forum, etc.  There's just ONE place left we can't figure out how to turn off.  The only thing left they can create (under their create drop down) is Recognition. How do we turn this off?

  • Answered

    Hi Tiffany,

    To disable recognition awarding for members, you'll need to update each badge. Go to Control Panel > People > Recognition and edit a badge.

    Uncheck the Member role in the "Roles that can grant" section and save the badge.

    Update this setting for all badges.

    Grace

  • Fantastic!!!!  That's the last permission we were stuck on. Now we are in great shape, thank you!

  • Hello - Ok, we went through each one, made sure on the permission (generally) that member wasn't checked for recognition or badges. Then went to each one and only checked admin and moderator.  It's still showing up in member under "create" as an option?

  • Hi Tiffany,

    Could you Rebuild Caches in Control Panel > System > Advanced System Utilities? Does this remove the Create > Recognition option for Members?

    Grace

  • Hi Grace,

     

    Not sure if the process itself worked... I get an alert (in blue) see attached and it doesn't appear anything happened.  I clicked the green button again, same screen. I waited a few minutes, logged out and into the other account, still see it from non-admin user.

    Attachments
  • Hi Tiffany,

    This seems to be a bug and I've made a case with our development team to fix it. We'll let you know once it's fixed.

    As a workaround, you can remove the view badges permission for Members. To do this, go to Control Panel > People > Recognition > Permissions. Uncheck the Badge View permission for the Member role, then click Save Permissions.

    Users with the Member role will no longer see Create > Recognition, Browse > Recognition, and the recognition tab on user profiles.

    Grace

  • Hi Grace -

    SORRY - now there's another issue. Now non-admins can't see their badges awarded at all.  I awarded a non-admin a site advisor badge. It's shown in the notifications but there isn't a Recognition tab in the left index (which is where Nathaniel said people could see their badges). 

     

    So we tried to turn the view back ON - still can't see it?  Refreshed, still can't see it.

  • Answered

    Hi Tiffany,

    The Badge > View permission was unchecked for the Member role in Control Panel > People > Recognition > Permissions. I checked it for you. You should be able to see the Recognition tab as a Member now.

    Grace

  • Hi Grace -

    Yes, it's visible now in the index on the left (in the profile). BUT, now the original problem is back too :).  If you click on Create they can create recognition and members cannot have that option. (See photo).

     

    Tiffany

  • Hi Tiffany,

    Our development team is working on a fix for the Create > Recognition option appearing when a user can't award any badges. We'll let you know when the fix is available.

    As a workaround, you can temporarily hide the Create > Recognition option with CSS, and hide the recognize button on recognition pages for Members.

    To hide the Create > Recognition option, add the following code in Control Panel > System > CSS Overrides. Note that this will hide the option for everyone.

    #ulMyMenuAddEntity #liRecognize {display:none;}

    To hide the recognize button on recognition pages for Members, follow the steps below.

    1. Open a recognition page with a recognize button (such as Browse > Recognition > Most Recent)
    2. Edit the page
    3. Edit the recognition Section widget
    4. Click the Roles tab
    5. Check the roles which you want to see the Recognize button and award badges
    6. Click Save Widget
    7. Click Publish changes

    Grace

Page 1 of 1 (13 items)