Loading ...

Required reading email notification not working | Communifire Support

Home » Spaces » Communifire Support » forum » Features and Functionality » Required reading email notification not working
Communifire Support

Leave Space :

Are you sure you want to leave this space?

Join this space:

Join this space?

Add a new tab

Add a hyperlink to the space navigation. You can link to internal or external web pages. Enter the Tab name and Tab URL. Upload or choose an icon. Then click Save.

The name that will appear in the space navigation.
The url can point to an internal or external web page.
Login to follow, share, and participate in this space.
Don’t have a support community login?Create your account now
Posted in: Features and Functionality

Required reading email notification not working

Subscribe to RSS
  • Xenon

    We're testing the required reading for articles. I have 5 members of a test space that should be receiving these notifications when I create a required reading article, but no one, including me, is getting them.

    My Space permissions:

    Space Settings:

    We don't do wall posts, so I have that disabled. I unchecked it to see if that was preventing the notification emails from being received, but that didn't seem to be the issue either. 

    Application Settings:

    Lastly, is there a way to make a required reading article stand out when users see it on the home page? Right now, it just looks like a regular article.

  • gskamau

    Hey Xeng,

    Do the users have email notifications enabled in Preferences ? Do the users see a notification in Communifire about the required reading?

    You can use a specific content category for required reading, check the category in the Page Builder template, then add some element to highlight the required reading. See the example below.

    {{#if (compare ContentCategoryName "Required Reading")}} <div><span class="required-reading-label"><i class="icon-asterisk"></i> Required Reading</span></div> {{/if}}

    This example uses a category named "Required Reading". You can add a new content category in Manage Space > Articles > Manage Space: Add Article Category .

    Grace

  • Xenon

    Grace,

    I remember updating the email address in the permission settings. Would this be the cause of it? I just updated the From email address to our company email, and updated the Friendly email name to our company name.

    All of the users have their preferences set to receive emails by the way.

    Other than that, we didn't configure anything to send it any differently. 

    I tried your suggested code. I added it within the category description when I created my new category for required reading. I noticed that the alert only appears on the article list page, but in my page builder, it does not.

    Article list page:

    Page builder page. Both are the same article, but they're just using a different template layout.

  • gskamau

    Hey Xeng,

    The changed From email address is likely the issue. Please set it back to the default.

    The code should be added to the Content List template the Page Builder widget uses. Go to Control Panel > System > Page Builder Templates , select Content List, and edit the appropriate template. The articles list in a space won't be affected.

    Grace

  • Xenon

    I added that code into the Content List template that the page builder is using, but I still don't see anything. The category I created was called as you suggested: Required Reading.

    Is there a way to update that email so that when employees get the notification, it's not coming from a source they never heard of? I think everyone will be cautious and not click on it to find the required reading article.

  • gskamau

    Hey Xeng,

    Add the code somewhere after the {{#each Contents}} and before the {{/each}}. This section is the part that is displayed for each item the widget pulls.

    To customize the From email address, you also need to update the SMTP server, username, password, and port. You can get these settings from your email provider.

    Grace

  • Xenon

    Thanks, Grace.

    I got the code to work when the stacked list template, but it goes a little crazy when I put in the carousel template.

    The Required Reading flashes when the page loads, but then the carousel shrinks. I put your code in the same area.

  • gskamau
      Answered

    Hey Xeng,

    Try adding the code above <h4><a title="{{{Title}}}" href="{{ContentURL}}">{{{Title}}}</a></h4> in the Carousel template.

    Grace

  • Xenon

    Thanks, Grace!

  • Xenon

    Grace Kamau 

    Where can I edit that class for the required reading? Also, are there other styling options when it comes to required reading or is that based on our HTML coding knowledge?

    My team and I are wanting to know what other options are there to call out required reading articles.

  • gskamau

    Hey Xeng,

    There aren't any settings for the required reading label. You can customize the default label using CSS Overrides . The class is required-reading-label .

    Grace

  • Xenon

    Hi, Grace.

    Am I able to change the string to say something else other than "Required Reading"? If so, where can I do that?

  • gskamau

    Hey Xeng,

    You can do this in Control Panel > System > Localized Content. Select Search resource value only and search for "Required Reading." Several results will come up for different places where "Required Reading" appears. Click the edit icon to edit the text.

    Grace

Page 1 of 1 (13 items)