Loading ...

OrgChart connections API method | Communifire Support

Home » Spaces » Communifire Support » forum » Communifire API & Developers » OrgChart connections API method
Communifire Support

Leave Space :

Are you sure you want to leave this space?

Join this space:

Join this space?

Add a new tab

Add a hyperlink to the space navigation. You can link to internal or external web pages. Enter the Tab name and Tab URL. Upload or choose an icon. Then click Save.

The name that will appear in the space navigation.
The url can point to an internal or external web page.
Login to follow, share, and participate in this space.
Don’t have a support community login?Create your account now
Posted in: Communifire API & Developers

OrgChart connections API method

Subscribe to RSS
  • arivera618

    I'm using this API to get the hierarchy for an employee.  It's getting connection errors, timing out errors when I'm using it.  I have a job that runs daily that updates user info and one of the things it does is update user hierarchy.  We have over 2200 employees so somewhere in the process it bombs out with the errors mentioned.  It's always at different points in the process. It also doesn't just happen with this API call it also happens when I try to add a profile photo.  I had emailed Matt Trujillo on the Wednesday before Thanksgiving to see if you guys were doing backend work and he said no.  I've done the infamous restart site and rebuild indexes and still same issue.  I'd appreciate it if someone can look into this because it's seriously hindering our processes that we're trying to put in place.

  • mtrujillo

    Hey Alex,

          Can you please provide more details about the error(s) you are seeing?

  • arivera618

    They are Server Connection error, Connection Timeout error, Server 404 Not Found error.

     

     

  • mtrujillo

    Hey Alex,

            Does the issue occur every single time the process runs or does it occur randomly. Do you have a date/time it occurred last? 

            Can you please post screenshots of the errors you see in the Communifire Exception Log when this happens?

            Can you please post screenshots of the errors your see on your end?

            The more detailed information we have, the faster the developer can troubleshoot/resolve this.

             If your screenshots contain sensitive information, please open a private case.

    Matt

  • arivera618

    It happens almost every time. It happens at different stages of while the program runs. The last time it happened was this past Monday and the Wednesday night before Thanksgiving.  I'm running now so as soon as it fails I'll send you screen shots of the errors.

     

    Alex

     

  • arivera618

    Here is the error I got today.

    System.Net.WebException
      HResult=0x80131509
      Message=The underlying connection was closed: A connection that was expected to be kept alive was closed by the server.
      Source=System
      StackTrace:
       at System.Net.HttpWebRequest.GetResponse()
       at intranet_update_users.Program.FollowHierarchy(String fromUserID) in C:\Projects\intranet-update-users\intranet-update-users\Program.cs:line 369
       at intranet_update_users.Program.CheckUserValues(String userID, String group, User user) in C:\Projects\intranet-update-users\intranet-update-users\Program.cs:line 213
       at intranet_update_users.Program.Main(String[] args) in C:\Projects\intranet-update-users\intranet-update-users\Program.cs:line 193
    Inner Exception 1:
    IOException: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    Inner Exception 2:
    SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
    Here is the screen shot from the Exception Log
  • mtrujillo

    Hey Alex,

           Do you know how long the process ran until it timed out? We are going to be conducting server work for your site this weekend, we will let you know when it's done so you can run your program again.

    Matt

  • arivera618

    It ran for about 45 minutes to an hour.

Page 1 of 1 (8 items)